Active Directory Authentication is reporting problems

Incident Report for CIT Geneseo Status

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 10:35 EDT

Monitoring

Appworx logons are available again, we are monitoring the system for additional issues.
Posted Aug 31, 2026 - 09:08 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 31, 2026 - 08:47 EDT

Identified

WE have narrowed it down to just Appworx, and ARGOS is working fine.
Posted Aug 31, 2026 - 08:47 EDT

Investigating

Appworx and ARGOS are showing issues with logons at this time.
Posted Aug 31, 2026 - 08:37 EDT
This incident affected: Administrative Systems (AppWorx).