www.geneseo.edu website experiencing intermittent page failures
Incident Report for CIT Geneseo Status
Resolved
This issue has resolved itself for now but we are continuing to investigate.
Posted Nov 19, 2022 - 08:12 EST
Update
The issue seems to have stopped for now, but we are continuing to monitor and investigate for the root cause.
Posted Nov 19, 2022 - 07:09 EST
Investigating
The www.geneseo.edu website is currently experiencing intermittent page failures with the message: "The website encountered an unexpected error. Please try again later.". We are investigating the cause of the issue.
Posted Nov 19, 2022 - 06:43 EST
This incident affected: Web (Geneseo Website).