Online Directory Page is not working on www.geneseo.edu
Incident Report for CIT Geneseo
Resolved
The online directory is working properly, please contact CIT if you have any issues.
Posted 27 days ago. Jan 23, 2019 - 08:44 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 27 days ago. Jan 23, 2019 - 04:11 EST
Investigating
The online directory page is failing on the Geneseo website. The web team is currently investigating the problem.
Posted about 1 month ago. Jan 17, 2019 - 10:45 EST
This incident affected: Web (Geneseo Website).