Slack Outage
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 20:12 EST
Monitoring
Slack appears to be working again for some users. please try reloading or quitting and relaunching the app if you are having issues. See here for more information https://status.slack.com/2021-01/9ecc1bc75347b6d1
Posted Jan 04, 2021 - 14:00 EST
Identified
Slack is experiencing an outage right now. This impacts the College's real time communication platform used by several offices. You can follow the status of the slack outage here https://status.slack.com/

We will post when it is working reliably again.
Posted Jan 04, 2021 - 11:25 EST