Widespread Computer Outage - No Systems at Geneseo Affected
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 10:34 EDT
Monitoring
The news media is reporting widespread computer outages related to CrowdStrike security software. Geneseo currently does not have systems with CrowdStrike installed, so we are not directly affected. Most businesses around the world are already recovered, but be aware that some may have lingering computer outages today.
Posted Jul 19, 2024 - 08:31 EDT