We are experiencing a service outage for the CAS Single Sign-On service used by my.geneseo.edu, knightweb, banner, and many other services. We are currently investigating and working to resolve the problem.
Incident Report for CIT Geneseo Status
Resolved
The service was restored by 7:45 am. We are continuing to research what caused the outage to determine if further action is required.
Posted Mar 30, 2020 - 08:51 EDT
Investigating
We are currently investigating this issue.
Posted Mar 30, 2020 - 07:43 EDT
This incident affected: Web (MyGeneseo), Administrative Systems (Banner), and Academic Services (Geneseo Mobile, KnightWeb).