mydevices.geneseo.edu gPlay registration portal is down
Incident Report for CIT Geneseo Status
Resolved
The portal is now operational. There was an unexpected IP address conflict.
Posted Aug 05, 2024 - 09:28 EDT
Update
We are continuing to investigate this issue.
Posted Aug 05, 2024 - 08:56 EDT
Investigating
We are currently investigating this issue
Posted Aug 05, 2024 - 08:55 EDT
This incident affected: Network & Wireless (Wireless Connectivity).