Argos is not responsive
Incident Report for CIT Geneseo
Resolved
This incident has been resolved.
Posted Mar 02, 2020 - 13:40 EST
Investigating
Argos is not responsive. We are investigating.
Posted Mar 02, 2020 - 13:18 EST
This incident affected: Administrative Systems (Argos).