Issues Reaching Some Microsoft Services

Incident Report for CIT Geneseo Status

Resolved

Microsoft has reported that the connectivity issues are resolved.
Posted Jul 23, 2026 - 18:00 EDT

Investigating

Microsoft has announced that some users may be having issues with OneDrive, SharePoint, Teams, and Power Automate. They are investigating and hope to share an update by 5pm. We will try to post an update this evening.
Posted Jul 23, 2026 - 14:45 EDT