Adobe Sign not functioning properly
Incident Report for CIT Geneseo Status
Resolved
Adobe has resolved the issue.

Today 5:07 PM (EST)
Impact severity: Major
Impact scope: Most customers are impacted.
Services impacted: Login(Direct Login), Send for Signature(Send for Signature), Signatures(Signatures), Tracking and Management(Manage Document Console, Reminders)
Environments impacted: Adobe Acrobat Sign North America 4
Impact update: We’ve resolved the issue.
Posted Jan 13, 2025 - 19:15 EST
Investigating
Today 12:35 PM (EST)
Impact severity: Major
Impact scope: Most customers are impacted.
Services impacted: Login(Direct Login), Send for Signature(Send for Signature), Signatures(Signatures), Tracking and Management(Manage Document Console, Reminders)
Environments impacted: Adobe Acrobat Sign North America 4
Impact update: An update on this issue has been posted as follows -
An unexpected issue is currently affecting the Acrobat Sign service on the NA4, you may experience slowness in sending and accessing agreements and delayed webhooks
Posted Jan 13, 2025 - 13:09 EST
This incident affected: Administrative Systems (Adobe Acrobat Sign).