Adobe is reporting issues with Adobe SIGN in North America

Incident Report for CIT Geneseo Status

Resolved

Adobe has resolved the issue.
Posted Mar 10, 2025 - 13:52 EDT

Investigating

Mar 10, 2025 10:49 AM (UTC-4)
Impact severity: Major
Impact scope: Some customers are impacted.
Services impacted: Send for Signature(Send for Signature)
Environments impacted: Adobe Acrobat Sign North America 1, Adobe Acrobat Sign Europe 1
Impact update: We’ve changed the severity level from minor to major for the availability issue.

Previous updates:
Mar 10, 2025 10:39 AM (UTC-4)
We’re investigating a performance issue.
Posted Mar 10, 2025 - 10:56 EDT
This incident affected: Administrative Systems (Adobe Acrobat Sign).