Navigate Login Errors
Incident Report for CIT Geneseo Status
Resolved
EAB applied the fix necessary and logins are working again.
Posted Jan 24, 2023 - 09:35 EST
Investigating
Many users are reporting log in errors when attempting to use EAB Navigate. We are in contact with EAB and hope to have a resolution soon.
Posted Jan 24, 2023 - 08:11 EST
This incident affected: Administrative Systems (Navigate).