Campus Email Outage
Incident Report for CIT Geneseo Status
Resolved
The authentication issue with Gmail has been resolved, and campus email should now be available again.
Posted Jan 13, 2021 - 07:15 EST
Investigating
We have received reports that some campus members are unable to access Google services, including email, because their login credentials could not be verified. We are looking into the issue now.
Posted Jan 13, 2021 - 07:04 EST
This incident affected: Google (Google Apps Gmail).