Erie Hall Network Outage

Incident Report for CIT Geneseo Status

Resolved

Network services and connectivity have been restored in Erie C.
Posted Feb 07, 2025 - 14:53 EST

Investigating

We are just now aware of and investigating a network outage in all of Erie C. We will share an update as soon as possible, or by 3pm.
Posted Feb 07, 2025 - 14:26 EST
This incident affected: Network & Wireless (Residence Hall Wired Connectivity, Wireless Connectivity, Internet Connectivity).