Geneseo website (www.geneseo.edu) Unavailable
Incident Report for CIT Geneseo Status
Resolved
The incident has been resolved and the website is working again.
Posted Dec 02, 2019 - 10:16 EST
Investigating
The Geneseo website is unavailable. We are currently investigating the cause.
Posted Dec 02, 2019 - 10:09 EST
This incident affected: Web (Geneseo Website).