Canvas Errors
Incident Report for CIT Geneseo
Resolved
Instructure has resolved the outage. Canvas is now operating normally. Thank you for your patience.
Posted Nov 06, 2019 - 20:48 EST
Identified
Instructure (the company that hosts Canvas) is aware that users are experiencing 500 errors when accessing Canvas. their developers are looking the issue currently. We will have an update to you as soon as possible.
Posted Nov 06, 2019 - 20:28 EST
This incident affected: Academic Services (Canvas).