Google Authentication Outage
Incident Report for CIT Geneseo Status
Resolved
We're seeing enough of a drop in failed authentications to believe this outage is resolved. If you receive a "login credentials could not be verified" error when logging in to Google, please wait a few minutes and try again.
Posted Dec 12, 2022 - 10:57 EST
Monitoring
We believe we have addressed the cause of the issue. Some people may still receive the error as the fix works its way through Google's systems - please try again every few minutes if you do.
Posted Dec 12, 2022 - 08:47 EST
Investigating
We are experiencing an issue with Google (gmail/calendar/drive) authentication. Existing connections are working, but any new authentication attempts fail. We are looking into the issue now.
Posted Dec 12, 2022 - 08:42 EST
This incident affected: Google (Google Apps Calendar, Google Apps Docs, Google Apps Drive, Google Apps Gmail, Google Apps Sheets) and Login Services (Active Directory).