Bailey Network Outage

Incident Report for CIT Geneseo Status

Resolved

All Services are back.

Network equipment had failed and has restarted properly.
Posted Jun 18, 2026 - 15:02 EDT

Investigating

Network is down in Bailey. We are diagnosing now. Next update by 3pm
Posted Jun 18, 2026 - 14:24 EDT
This incident affected: Network & Wireless (Academic/Administrative Wired Connectivity).