Welles WiFi Network Issues

Incident Report for CIT Geneseo Status

Resolved

We have found and fixed two issues that were causing this problem. The wireless network in Welles is now fully operational.
Posted Aug 30, 2022 - 11:32 EDT

Investigating

We are investigating reports of users unable to join the wifi in Welles hall.
Posted Aug 30, 2022 - 08:31 EDT
This incident affected: Network & Wireless (Wireless Connectivity).