Issues connecting to Central Authentication Server
Incident Report for CIT Geneseo Status
Resolved
Sign-ins are now working normally. Thank you for your patience.
Posted May 12, 2020 - 09:35 EDT
Monitoring
The authentication issue appears to be resolved. We are continuing to monitor.
Posted May 12, 2020 - 07:04 EDT
Investigating
We have reports of issues connecting to the Central Authentication Server and are investigating.
Posted May 12, 2020 - 06:31 EDT
This incident affected: Login Services (CAS Server).