Docuware unavailable
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Jan 12, 2022 - 07:44 EST
Investigating
We have been researching issues with Docuware (related to the database) since approximately 5am. We hope to have services restored shortly.
Posted Jan 12, 2022 - 07:35 EST
This incident affected: Administrative Systems (Docuware).