Network Outage in Blake A

Incident Report for CIT Geneseo Status

Resolved

We have successfully moved Blake A off the damaged fiber, all services are returning now.
Posted Mar 31, 2025 - 07:51 EDT

Identified

We have determined that we have a failed strand of fiber-optic cable between South Hall and Blake Hall. We are about to begin switching to different cable now. We hope to have service restored as close to 8am as possible.
Posted Mar 31, 2025 - 07:41 EDT

Investigating

We are investigating a network outage in Blake A. All internet, print, voice, data, and wifi services are down in the Blake A CAS area.
Posted Mar 31, 2025 - 07:20 EDT
This incident affected: Network & Wireless (Wireless Connectivity, Academic/Administrative Wired Connectivity, Internet Connectivity) and Campus Services (Telephone Services).