Docuware is unavailable

Incident Report for CIT Geneseo Status

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 10:49 EDT

Investigating

We are investigating an issue with Docuware. It is currently unavailable.
Posted Mar 11, 2025 - 10:35 EDT
This incident affected: Administrative Systems (Docuware).