Network Outages Across Campus

Incident Report for CIT Geneseo Status

Resolved

Power is back everywhere on campus. Services are restored.
Posted Jun 09, 2025 - 15:12 EDT

Update

The power outages continue across campus. Now Ontario is down.
Posted Jun 09, 2025 - 14:48 EDT

Identified

The storm is bringing power outages across campus. Network services are down in Erie, Niagara, Steuben and the Stadium right now. We will watch the storm and see what we can do to get services restored.
Posted Jun 09, 2025 - 14:26 EDT
This incident affected: Network & Wireless (Residence Hall Wired Connectivity, Wireless Connectivity, Academic/Administrative Wired Connectivity, Internet Connectivity).