Campus WiFi Outage
Incident Report for CIT Geneseo Status
Resolved
WiFi has continued to operate normally today.
Posted Sep 17, 2024 - 12:47 EDT
Monitoring
Restarting wireless login servers has restored service. We are watching the servers closely for issues this morning.
Posted Sep 17, 2024 - 10:39 EDT
Investigating
We are investigating an issue with connecting to campus WiFi. Both eduroam and gplay are unavailable right now.
Posted Sep 17, 2024 - 10:09 EDT
This incident affected: Network & Wireless (Wireless Connectivity).