KnightWeb unavailable
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 16:15 EDT
Investigating
KnightWeb is currently unavailable. We believe we have identified the issue and are starting services now.
Posted Jul 14, 2020 - 16:10 EDT
This incident affected: Academic Services (KnightWeb).