Cloudflare Global Network experiencing issues Update - Cloudflare services are currently operating normally. We are no longer observing elevated errors or latency across the network.
Our engineering teams continue to closely monitor the platform and perform a deeper investigation into the earlier disruption, but no configuration changes are being made at this time.
At this point, it is considered safe to re-enable any Cloudflare services that were temporarily disabled during the incident. We will provide a final update once our investigation is complete. Nov 18, 2025 - 17:44 UTC
Posted Nov 18, 2025 - 13:53 EST
Identified
There is currently an outage with Cloudflare that is affecting logons to Brightspace, DegreeWorks, Time & Attendance, and other services that make use of SUNY logons.
Posted Nov 18, 2025 - 08:09 EST
This incident affected: Academic Services (Brightspace, Degree Works) and Login Services (SUNY Portal).