F5 Load Balancer outage - VPN and myGeneseo unreachable

Incident Report for CIT Geneseo Status

Resolved

The networking issue with the load balancer has been resolved. VPN, myGeneseo, and all other affected web services have been restored.
Posted Aug 13, 2026 - 09:01 EDT

Update

We are continuing to investigate the issue. The F5 load balancer is responsive again, but networking remains unavailable. VPN, myGeneseo, and other webapps like go.geneseo.edu, transfer articulation, and the directed study form remain down. We will update this status by 9am.
Posted Aug 13, 2026 - 08:21 EDT

Investigating

We are currently investigating an outage with the the campus load balancer that directs traffic to services like VPN and myGeneseo. Those services are down until the issue is resolved.
Posted Aug 13, 2026 - 07:37 EDT
This incident affected: Web (MyGeneseo) and Network & Wireless (VPN).