Print Services Outage
Incident Report for CIT Geneseo Status
Resolved
An issue was identified with Pharos Cloud logins and Pharos Systems was able to resolve the issue.
Posted Sep 26, 2023 - 08:45 EDT
Investigating
We have received reports of problems authenticating to Pharos to print through Web Print or through the Pharos Secure Release application. Existing connections do not appear to be impacted, but new sign ins are not working at this time. We are investigating the problem and have contacted Pharos support.
Posted Sep 26, 2023 - 08:11 EDT
This incident affected: Campus Services (Printing (Pharos Cloud)).