Argos is unresponsive
Incident Report for CIT Geneseo
Resolved
This incident has been resolved.
Posted Mar 05, 2020 - 10:44 EST
Investigating
Argos is unresponsive. We are investigating.
Posted Mar 05, 2020 - 10:29 EST
This incident affected: Administrative Systems (Argos).