Unity Voice Mail Server
Incident Report for CIT Geneseo Status
Resolved
Restart resolved issue.
Posted Apr 11, 2018 - 08:55 EDT
Investigating
Unable to access, restarting Voice Mail Server.
Posted Apr 10, 2018 - 08:35 EDT
This incident affected: Network & Wireless (Academic/Administrative Wired Connectivity).