Docuware database restart
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 07:33 EDT
Investigating
Docuware will be unavailable for approximately 10 minutes while we restart the database.
Posted Aug 11, 2022 - 07:24 EDT
This incident affected: Administrative Systems (Docuware).