Knightweb is not available. There is a problem logging in
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Feb 18, 2020 - 23:34 EST
Investigating
We are currently investigating this issue.
Posted Feb 18, 2020 - 22:20 EST
This incident affected: Academic Services (KnightWeb).