Single Sign-On Authorization Server issue
Incident Report for CIT Geneseo
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 08:39 EDT
Investigating
An issue with our Single Sign-On Authorization Servers has been identified and is being repaired. Services should be completely restored within 10 minutes.
Posted Apr 01, 2020 - 08:33 EDT
This incident affected: Login Services (CAS Server).