Banner and Knightweb services unavailable
Incident Report for CIT Geneseo Status
Resolved
Banner and Knightweb services should be operational again.
Posted Oct 28, 2022 - 12:48 EDT
Investigating
Banner and Knightweb services are currently unavailable. We are currently investigating the issue.
Posted Oct 28, 2022 - 11:52 EDT
This incident affected: Academic Services (KnightWeb) and Administrative Systems (Banner).