Geneseo Website Certificate Issue

Incident Report for CIT Geneseo Status

Resolved

We have updated the certificate and www.geneseo.edu and my.geneseo.edu are now working properly.
Posted Aug 08, 2022 - 07:24 EDT

Identified

We are aware of an issue with www.geneseo.edu, my.geneseo.edu, and other geneseo sites saying the certificate has expired. We are working to resolve the issue now.
Posted Aug 08, 2022 - 07:18 EDT
This incident affected: Web (Geneseo Website, MyGeneseo).