Campus PCI (credit card) Network is down.
Incident Report for CIT Geneseo Status
Resolved
Spectrum had an outage, it is now resolved. The campus PCI network is now operational.
Posted May 01, 2020 - 12:07 EDT
Investigating
We are currently investigating an outage of the campus PCI network. This network supports credit card terminals and transactions for CAS and a few other departments.
Posted May 01, 2020 - 10:12 EDT