Microsoft Azure Connectivity Issues

Incident Report for CIT Geneseo Status

Resolved

The issue impacting connectivity to Microsoft Azure services has been resolved. Please ask CIT for assistance if you are still encountering any errors.
Posted Oct 30, 2025 - 06:59 EDT

Identified

We have received reports of some connectivity issues to Microsoft Azure cloud applications, including CoPilot, login services, and Office. According to https://azure.status.microsoft/en-us/status, Microsoft is attempting to apply a mitigation to restore access.
Posted Oct 29, 2025 - 15:22 EDT
This incident affected: Login Services (Active Directory).