knightweb service will be temporarily unavailable - Servers are getting OHS connection errors and need to be restarted.
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 10:16 EDT
Investigating
We are currently investigating this issue.
Posted Apr 01, 2020 - 22:12 EDT
This incident affected: Academic Services (KnightWeb).