Adobe Sign is currently experiencing issues

Incident Report for CIT Geneseo Status

Resolved

No further issues have been reported.
Posted Jul 02, 2024 - 12:59 EDT

Monitoring

Adobe reports that the issue has been resolved.
Posted Jul 02, 2024 - 10:34 EDT

Investigating

Impact scope: Some customers are impacted.
Services impacted: Login(Console Login), Send for Signature(Send for Signature)
Environments impacted: Adobe Acrobat Sign North America 1
Impact update: This issue has been determined to be impactful. We're investigating a performance issue.
Posted Jul 02, 2024 - 09:46 EDT
This incident affected: Administrative Systems (Adobe Acrobat Sign).