Login errors
Incident Report for CIT Geneseo Status
Resolved
We have resolved the problem with sign-ins. All sign-ins should be working again.
Posted Mar 02, 2020 - 11:04 EST
Investigating
We are aware of an issue with signing into many web applications. We are investigating the issue and hope to have it resolved soon.
Posted Mar 02, 2020 - 11:02 EST
This incident affected: Login Services (CAS Server, SUNY Portal), Academic Services (Degree Works, Geneseo Mobile, KnightWeb), and Administrative Systems (Banner, PointNClick Electronic Medical Records, Symplicity Residence).