Google Drive desktop outage

Incident Report for CIT Geneseo Status

Resolved

People experiencing this problem been reporting that, after rebooting, their Google Drive client app is working again. If you reboot your computer and are still unable to sign in to the Windows/macOS Google Drive desktop app, please reach out to the CIT HelpDesk via one of the methods at https://www.geneseo.edu/cit.
Posted Jul 16, 2025 - 15:10 EDT

Investigating

We have received several reports that users are seeing a popup that Google Drive access has been restricted to authorized devices and has logged them out of their account. As far as we are aware, web access to Google Drive is unaffected. We are investigating the problem now.
Posted Jul 16, 2025 - 14:08 EDT
This incident affected: Google (Google Apps Drive).