The secure web certificate on Xtender has expired

Incident Report for CIT Geneseo Status

Resolved

The certificate issue has been resolved. Please contact the CIT HelpDesk if you encounter any additional issues with XTender.
Posted Aug 17, 2026 - 09:59 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 17, 2026 - 08:09 EDT

Investigating

We are currently working on acquiring a new certificate.
Posted Aug 17, 2026 - 08:09 EDT
This incident affected: Administrative Systems (Xtender - Banner Document Management System).