Campus Internet Redundancy Impacted
Incident Report for CIT Geneseo Status
Resolved
Repairs to our fiber optic cables have been completed, full redundancy has been restored.
Posted Jan 14, 2021 - 08:42 EST
Update
Repairs to the cut fiber continue, and should be complete by 7pm.
Posted Jan 13, 2021 - 16:37 EST
Update
There has been a cut to a fiber optic cable outside Buffalo. Contractors are on site and repairs are beginning.
Posted Jan 13, 2021 - 14:08 EST
Identified
Our fiber optic provider has identified an issue with a fiber optic connection between Albion, NY and Buffalo, NY. No estimated time to repair has been given.
Posted Jan 13, 2021 - 13:03 EST
Investigating
We are investigating a new issue with one of our links to the internet - one of them is down. There is no impact to the community at this time because of the redundancy.
Posted Jan 13, 2021 - 13:02 EST
This incident affected: Network & Wireless (Internet Connectivity).