Banner 8 Forms service unavailable
Incident Report for CIT Geneseo
Resolved
The Banner8 forms service is working again.
Posted 3 months ago. Mar 04, 2019 - 08:39 EST
Investigating
The Banner8 forms service is currently unavailable. We are investigating, but at this point other Banner services appear to be working properly.
Posted 3 months ago. Mar 04, 2019 - 08:22 EST
This incident affected: Administrative Systems (Banner).