The upgrade of BDM/Xtender to the new version called BDM/Enhancer is complete and ready for use. Please alert us to any irregularities you might notice.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 05, 2025 - 10:00 EDT
Scheduled
This weekend, we will be performing an upgrade to the Xtender component of Banner. Please note that this upgrade will affect only Xtender; all other portions of Banner will remain fully operational.
The upgrade is scheduled to begin on Sunday and continue through Monday to allow adequate time for thorough testing before Xtender is returned to full service.
If you experience any issues or have questions during this time, please don’t hesitate to contact us.
Thank you for your understanding and support.
Posted Oct 02, 2025 - 15:58 EDT
This scheduled maintenance affected: Administrative Systems (Xtender - Banner Document Management System).