Network Outage in Fraser

Incident Report for CIT Geneseo Status

Resolved

Our network connections form South hall to Fraser are stronger now than before today's issues, now that we are on different fiber optic strands going into the building. All services are restored, better than before. Thank you for your patience today.
Posted Jan 21, 2026 - 15:06 EST

Monitoring

We are switching to other strands of buried fiber optic cable to restore network service in Fraser. Things are coming back on line now.
Posted Jan 21, 2026 - 14:48 EST

Investigating

We are diagnosing a network outage in Fraser. Ground and main floors are off line, upstairs unaffected.
Posted Jan 21, 2026 - 14:43 EST
This incident affected: Network & Wireless (Wireless Connectivity, Academic/Administrative Wired Connectivity).