DegreeWorks unavailable
Incident Report for CIT Geneseo Status
Resolved
Our SUNY hosting partner (iTEC) indicates they have resolved the DDoS (Distributed Denial of Service) attack on DegreeWorks and the service should be operational. They have experienced several of these malicious attacks targeted at their data center over the last couple weeks. We apologize for the interruption in service.
Posted Sep 11, 2018 - 11:10 EDT
Investigating
DegreeWorks is unavailable due to a DDoS attack at the host data center. We will provide updates as we receive them.
Posted Sep 11, 2018 - 08:12 EDT
This incident affected: Academic Services (Degree Works).