Campus Network Outage
Incident Report for CIT Geneseo Status
Resolved
Spectrum has identified and repaired the cable issue. Service returned at 1:11am this morning.
Posted Nov 19, 2019 - 06:43 EST
Update
This network outage is larger than just the campus - it is impacting approximately 600 cable modem customers and 7 enterprise/fiber customers in the village of Geneseo. Spectrum personnel are actively looking for the cause of the outage.
Posted Nov 18, 2019 - 18:39 EST
Investigating
We are investigating a campus network outage. One of our two ISP connections has gone down. Our redundant design makes this outage mostly invisible to our users, except for connections to our Syracuse data center and some connections may be slightly slower.
Posted Nov 18, 2019 - 16:17 EST
This incident affected: Campus Services (General Announcement).