Argos unavailable
Incident Report for CIT Geneseo
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 10:32 EST
Investigating
Argos is currently unavailable. We are researching.
Posted Nov 14, 2019 - 10:26 EST
This incident affected: Administrative Systems (Argos).